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File placement

Linux under virtualbox

the file shared between windows and
—“ Shared folder

mount dir

_m NFS mount dir
linux-digilent

windows

bootbin Generated BOOT.BIN file.

sl etaa=r-n| devicetree file.

driver file.

driver

Xps projects

e e ramdisk mount dir

Zedboard_Linux_Design prebuilt SD image

arm kernel files and
scripts to build device tree.



Outline

 Why don’t we use files in prebuilt SD image?
— The prebuilt SD image contain some other designs.

— We need to build our own hardware design.

* In this slide, we will focus on building an empty
hardware design.



Requirement

* Xilinx EDK tools: 14.4 version or later
(Note: 14.2 cannot generate devicetree files and

occurs some problems when creating new project)
— Xilinx Platform Studio (xps)
— Xilinx Software Development Kit (sdk)

* Linux environment: Please refer to Lab O. You’ll need
the followings:

— Device tree compiler(DTC): This will appear once you’ve
compiled kernel image.

— Cross compiler
* My platform:

— Win 7 with i7 cpu 32G ram.

— Ubuntu 12.04 64-bit server version on virtualbox, single
core and 8G ram



Workflow - generate BOOT.BIN

* In XPS

— Create your design in XPS
— Export to SDK: get system.bit

* In SDK

— Generate (or recompile) FSBL project: get fsbl.elf

— Create BOOT.BIN from system.bit, fsbl.elf we just
generated and u-boot.elf (under boot_image) from

prebuilt files.
: : > SDK: Create FSBL
XPS: Hardware design fsbl.elf
Generate bitstream
Export to SDK system.bit

SDK: Create Boot Image —> BOOT.BIN

u-boot.elf

fetch u-boot source




XPS create a new project

Under Xilinx Design Tools->ISE Design Suite 14.4->EDK->Xilinx Platform Studio
Note: Another way is to open XPS through PlanAhead.

Hilinx Design Toals

DocMav

ISE Design Suite 14.4
Accessories
ChipScope Pro
Documentation
EDK
& Xilinx Platform Studio
@» Xilinx Software Developme

Diocumentation

Tools



£ Base System Builder -- AXI flow

Board and Swystem Selection

Select a target development board and a Swstemn Template.

Board,

Board, Configuration
Architectore |2amg

Packaze clzdad

Select a Sstem

Zynqg Processing System 7

elopment Board (Pre-selected Device Info)

Board Name | £edBoard Zamg Evaluation and Deve]xE Boand Eevigion |(C

Dievice w020 Reference Clock Freguency (10000 MHz
Speed Grade |-1 Feset Folaritr Active High [] Use Stepping
Borstemn Information

Thiz swstern consists of Processing Bystem 7 with peripheral GPIOz, Peripherals
are connected on AXT mterconnect. Click Nexd to modify the defanlt swstem.

Board Vendor: Avnet

Board Name: Zedboard Zynq

Next



@ Base System Builder -- 83 flow

L2 |

Peripheral Confignration

To add a peripheral, drag it from the "Awvailable Peripherals” list to the Included Peripherals list. To configire & core parameter, click on the peripheral.

Belect and Configure Peripherals

Lvailable Peripheralz

Peripheral Mames

El 10 Devices
- BThs_5Bits
- EWWs_BBits
- LEDs_8Bits
El Internal Peripherals
- axi_bram_ctrl
- axi_timebase_wdt

-~ axi_timer

Press Select All
And then Remove
Finish

Add =

Tncluded Peripherals for Processing Sarstemny

Select 411

Caore

< Femove

Farameter




Puoject

HDE@

2y ‘ Bug Interfaces | Parts | Ldd s ‘

Navigator 3 ‘
|

Run DRCs

Tmplement Fow

Genetats Nedlist

Generat: Bithtream

Eport Design

Simulstion Flow

Generate HDL Files

Lannch Simulstor

Platform

= Project Files

- MHS File: system.mhs

- UCF File: data\system.uct

- IMPACT Command File: etc/download.cmd
- Implementation Options File: etc/fast_runtime.opt
- Bitgen Options File: etc/bitgen.ut

- Elf Files

=- Project Options

- Device: xc72020clg484-1

- Netlist: TopLevel

- Implementation: XPS (Xflow)

- HDL:VHOL

- Sim Model. BEHAVIORAL

- Design Summary

@ <+ =
Help Impont  Export  Summary
P Processing System (FS)
li0 Peripherals General Reset Application Processor Unit (APU)
Settings
MEON™JFPU Engine NEON™/FPU Engine
Bank0o
MID < Cortex™-AS Cortex™-A9
15 MMU MPCore™ MMU MPCore™
(150 SLV:iT CPU CPU
- Control 32KBI 32KBD 32KB | 32KBD 64b
Regs Cache Cache Cache Cache AXI
o “ » cic Snoop Control Unit ACP
e DMAS Slave
MIO) -+ Channel 512KB L2 Cache & Controller
> ocm | 256KB OCM
. - Interconnectl BootROM
Central
Bank1 4 ‘
MIO FLASH Me mory Interconnect | : | *
(63:16) Interfaces — Al | DAP I
— Memoryinterfaces
| P " bl DDR2I3, LPDDR2 i
S DEVC rogrammable I \ I
Logicto Memory Controller
y
DMA yne 12 (13 (14|15
Input Clock o I Clock
EFreq 2 P Generation
Extended MIO High Performance ‘ XADC
(EMIO) PSto PL AX|32bl64b Slave
Clock Ports Ports
- Select
GTX AMBAG Connection Legend Programmable Logic (PL) 110
(12'55 Arrow direction shows control, Data flows both directions
ps) Configurable AXI3 32 bit/é4 bit PCle
AXI3 64 bit [ AXI3 32 bit AHB 32 bit/ APE 32 bit Gen2

A control panel will show up. You can make some modification. But how to

add something is not the topic now. Click Export Design to generate an empty

bit stream and export it to SDK as well.




% | Export to SDK / Launch SDK L2 |
@_ Thiz dialog allows won to export hacd ware
Y platform information to be nsed in SDK.

J| lclude bitetresomn and BMM file

CLPE will regenerate bitstream if necessary,
| and it may take some time fn finish )
|

Directory location for hardyware description files
[5Zed board wdlindepsiclean' S DESEDE Export

[ Expoit Oy ] Export & Launch SDKj“ Cancel | | Help

Check Include bitstream and BMM file
and then Export & Launch SDK for convenience

XPS will start to generate bit stream. For an empty design, this should be
several minutes. SDK will automatically activate after bit stream generate. And
the hardware information will also export to SDK.

The system.bit will occur under Zedboard\xilinx\xps\clean\SDK\SDK_Export\hw
For the first time you launch SDK, you will need to specify workspace.
As for me: Zedboard\xilinx\sdk



File | Edit Source Refactor MNavigate Search Run  Project Xilink Tools Window Help

Mew Alt+Shift+N » | &) Application Project
Open File... i, Board Support Package
Close Ctrl+ W % Project...
Cloze all Ctrl+Shift+W | &% Source Folder
Save Ctrl+5 [ Folder
Save As.. |£,¢ Source File
Save Al Curl+shiftes | (B HeaderFile
Revert | % File from Template
(& Class
Mowe._.
Rename... F2 F Other... Ctrl+M

Now we want to generate fshl.elf
In SDK
File->New->Application Project



Application Project .
Create a managed make application project. &

Project name] fsbl

Use default location

D\ Zedboard\xilindsdiifsbl Browse...
default

Target Hardware
Hardware Platform [clean_hw_plaﬂc-rm v]
Processor [ ps7_cortexad_0 - ]
Target Software
05 Platform [standalone v]
Language @ C) O C++

Board Support Package @ Create New  fsbl_bsp

Use existing

@:l < Back [ Mext = ] [ Finish ] ’ Cancel

Give the new project a name, like fsbl/
Choose standalone for OS Platform and C for Language
Remain other settings as default and then Next



r hl
MNew Project E‘Elg

Templates _
Create one of the available templates to generate a fully-functioning @

application project.

Available Templates:

Dhrystone First Stage Bootloader (FSBL) for Zyng. =«
Empty Application The FSBL canfigures the FPGA with HWW
Hello Warld bit stream (if it exists) and loads the

lwIP Echo Server Operating System (0%) Image or
Memory Tests Standalone (SA) Image or 2nd Stage
Beuipberal Tacts Boot Loader image from the

non-volatile memary
(MAND/MOR/QSPD to RANM (DDR) and
starts executing it. It supports multiple
partitions, and each partition can be a
code image or a bit stream.

@ Mext = i Finish ] [ Cancel

Choose Zynq FSBL as templates
and then Finish



L4 Project Explorer 53 =08

a g clean_hw_platform
[£ ps7_initc
ps7_init.h
i@ ps7_init.html
= ps7_inittcl
|Z| system.bit
5 systemxml

a | fsbl

» gff Binaries

» [l Includes

: = Debug

- = src

a [ fsbl_bsp

. 1 BSP Documentation

» 2= ps/_cortexald_0
| libgenlog
[Z| libgen.options
Makefile
[k, system.mss

After finish, SDK will compile fsbl automatically.
The fsbl.elf will appear under Zedboard\xilinx\sdk\fsbl\Debug



Zilinx Tools | Window Help

Generate linker script
Board Support Package Settings

Repositories

Program FPGA
Program Flash

*MD Consaole

Launch Shell

Configure JTAG Settings

System Generator Co-Debug Settings

XK B D=E

Create Zynq Boot Image

Finally, we can create our clean BOOT.BIN
Click Xilinx Tools -> Create Zynq Boot Image



Create Zyng Boot Image

Create Zyng Boot Image

Creates Zynq Boot Image in .bin and .mcs formats from given FSBL elf and partition files in specified output

List of partitions in the boot image.

folder.
 Basic | Advanced|
Bif file ’Createa new bif file...
FSBL elf D:\Zedboard\dlindsdkifsblDebug\fsbl.elf

File
D ZedboardxdlindsdlkifsbhDebugifsbl elf

D Zedboardxilindxpsicleany 50K\ SDK_Exportihwhsystem. bit
DM Zedboard \ZedBoard_Linux_Designiboot_imageiu-boot. elf

Offset

Alignment Al Add

4|

T

Cutput folder D*Zedboard'bootbin

@

[ Create Image ] ’ Cancel

Choose Create a new bif file and then select FSBL, system.bit, and u-boot.elf
FSBL: Zedboard\xilinx\sdk\fsbl\Debug\fsbl.elf

bitstream: Zedboard\xilinx\xps\clean\SDK\SDK_Export\hw\system.bit
u-boot:Zedboard\ZedBoard_Linux_Design\boot_image\u-boot.elf €—

Create Image

Note that we use the file in
prebuilt SD image.

Finally, as | selected, u-boot.bin will appear under Zedboard\bootbin. Rename it as BOOT.BIN and

we’re done.

Note : The order is important!! Please follow the sequence.



A quick test

If you just can’t wait, you can try to replace the BOOT.BIN of the prebuilt
image.

But you’ll see this:

SadE bvtes

~eading

pplication at
Uncompressing Linux... done,

And then zedboard hangs.
This is because we’re not using the right devicetree.dtb
Note: As you modify the hardware, be sure to update your device tree blob!!



Workflow — generate device tree blob

Export the hardware designh to SDK:

— In XPS, Export Design just like we have done.

Add Device Tree Generator

— You only have to do this as the first time you generate device tree blob.

Create device tree project

— SDK will then generate dts file. But it need some
modification before compiling.

e Compile dts to dtb

— As far as | know, this can only done under Linux. And your should
compile kernel to get the compiler.

XPS: Hardware design SDK: Generate devicetree compiler(DTC)

Generate bitstream > ) > devicetree.dtb
devicetree.dts
Export to SDK




Xilinx / device-tree % Star 5 D Fork 18

Linux device tree generator for the Xilinx SDK

<} Code
305 commits 3 branches 10 releases 3 contributors
(@ lssues 2
E P branch: master ~ = device-tree / 4 I'l Pull Requests 0
axivdma: Make boolean DT properties real bools -

- Pulse

Srikanth Thokala authored 3 months ago latest commit 052cbS21f6 B

* michalsimek committed 3 months ago -
il Graphs

data axivdma: Make boolean DT properties real bools 3 months ago

b Network

First we download the device tree repositories. HITPS cone L
Under Windows: https://github.com/Xilinx/device-tree =~ : B

. You can clone with HTTPS or
and you can download the Device Tree Generator Subversion. ©

. (& Clone in Desktop
Or under Linux

¢ Download ZIP

simply use the git command
git clone git://github.com/Xilinx/device-tree.git


https://github.com/Xilinx/device-tree

In order for SDK to correctly find the repositories, the hierarchy should look like this.

4 || devicetree )
|| device-tree_v2_1 O.mld
git
g | | device-tree_w2_1_0.tcl
a4 | bsp
a | device-tree w0 00 x
| data

In SDK, Xilinx Tools -> Repositories

Kilinx Tools | Window Help

Generate linker script
Board Support Package Settings

Repositories

Program FPGA

Program Flash

*MD Consale

Launch Shell

Configure JTAG Settings

System Generator Co-Debug Settings

NXECAFK B =EF

Create fynqg BootImage




Preferences

type filter text
General
C/C++
Help
Install/Update
Remaote Systerns
Run/Debug
Team
Terminal
Hilinx SDK

BootImage

Add. remove or change the order of SDK's software repositories.

Local Repositories (available to the current workspace)

DM Zedboard\devicetree

Press New and then add Zedboard\devicetree

OK




[Fla Edit Source Refactor Mavigate Search Run  Project Xilink Tools Window Help
Mew Alt+Shift+N » | & Application Project
Open File... W, Board Support Package
Close Ctrl +\W 3 Project..
Cloze All Ctrl+Shift+W | % Source Folder
Save Ctrl+5 G5 Folder
Save As._ ¢/ Source File
Save All Crl+Shiftsg | B HeaderFile
Bevert | % File from Template
& Class
Mowe. .
Rename. £a % Other_ Ctrl+M

File -> New -> Board Support Package




Mew Board Support Package Project

Xilinx Board Support Package Project
Create a Board Support Package.

Project name: device-tree_bsp_0

Use default location
Location: | DAZedboard\xilindsdkidevice-tree_bsp_0

Choose file system: |default

Target Hardware

Browse._.

Hardware Platform: ’clean_hw_platform

CPU- ’pcs?_cc —

Board Support Package OS

I | [Generate flat device tree

@ Finish

Cancel

Choose device-tree and then Finish



Board Support Package Settings

device-tree_bsp_ 0

console device

periph_type_overrides

-
.”‘3 ]
L

Board Support Fackage Settings

Control various settings of your board support package.

YWalue

05 Type: device-tree
05 Version: 0.00x -
Mame
bootargs

console=ttyPS0,115200...
ps/_uart_1 -

efault

Type
string
peripheral
string

Description
Booting arguments
Instance name of IP core for boot console (e.g. R5232_Uart...

List of peripheral type overrides

O ] [ Cancel

Set bootargs as:

console=ttyPS0,115200 root=/dev/ram rw initrd=0x800000,8M earlyprintk rootwait

devtmpfs.mount=1
And choose console device as ps7_uart 1

OK

After building, you can find xilinx.dts under

Zedboard\xilinx\sdk\device-tree_bsp 0\ps7_cortexa9 O\libsrc\device-tree_vO 00 x
Copy xilinx.dts to Zedboard\devicetree and rename it as devicetree.dts



Modify dts to fit zedboard

* |t seems there are some inappropriate settings
for the dts generating.

* Open dts files and change the followings

Line 21:
compatible = "xInx,zyng-7000";
model = "Xilinx Zynqg";

Search for qspi

ps7_qspi_0: ps7-gspi@e000d000 {
clock-names = "ref _clk", "aper_clk";

=

=

Line 21:
compatible = "xlnx,zynqg-zed";
model = "Xilinx Zynq ZED";

ps7_qspi_0: ps7-gspi@e000d000 {
bus-num=<0>;
clock-names = "ref _clk", "aper_clk";

Add a new line for bus-num setting




Compile dts to dtb

* The compiling script is ~/win/linux-digilent/scripts/dtc/dtc
 Compile dts to dtb by

cd ~/win/devicetree
~/linux-digilent/scripts/dtc/dtc -I dts -O dtb -o devicetree.dtb devicetree.dts

hadoop@ubuntu:~/win/devicetree$ ~/linux-digilent/scripts/dtc/dtc -I dts -0 dtb -o

devicetree.dtb devicetree.dts
DTC: dts->dtb on file "devicetree.dts"

Reference: website



http://www.wiki.xilinx.com/Build+Device+Tree+Blob

Test again

Replace devicetree.dtb with the prebuilt image.
And boot the zedboard again.

Configure static IP 192.168.1.10
Starting telnet daemon

Starting http daemon

Starting ftp daemon

Starting dropbear (ssh) daemon
Starting OLED Display
Exporting LEDs & SWs

~cS Complete

Congratulation!!!!



